Difference between revisions of "Installing SLES9 32Bit and Smart PackageManager with FAI"

From FAIWiki
Jump to: navigation, search
 
m (+ category)
 
(2 intermediate revisions by 2 users not shown)
Line 1: Line 1:
=== create Yast Repository ===
+
== Introduction ==
 +
It is possible to install Suse with FAI and we do this successfully. We do it with the speciality that we don't use yast for package management but smartpm, and documented this here.
 +
 
 +
For some generic information on using FAI with other distributions, you can look at the [[FAI multi-distribution]] page.
 +
 
 +
== Create Yast Repository ==
 
# Copy all SLES9*.iso files to /var/www/SuSE/SLES9_repository  
 
# Copy all SLES9*.iso files to /var/www/SuSE/SLES9_repository  
 
#get make_sles9_repository Script
 
#get make_sles9_repository Script
Line 10: Line 15:
 
#:<pre>./upgrade_sles9repository_withsp.sh [SP]</pre>
 
#:<pre>./upgrade_sles9repository_withsp.sh [SP]</pre>
  
=== patch FAI install_packages for Smart ===
+
== Patch FAI install_packages for Smart ==
 
# get patch
 
# get patch
 
#:<pre>wget http://altf4.org/fai/SuSE/fai_smart.patch -O /tmp/fai_smart.patch</pre>
 
#:<pre>wget http://altf4.org/fai/SuSE/fai_smart.patch -O /tmp/fai_smart.patch</pre>
Line 16: Line 21:
 
#:<pre>patch /srv/fai/nfsroot/usr/sbin/install_packages /tmp/fai_smart.patch</pre>
 
#:<pre>patch /srv/fai/nfsroot/usr/sbin/install_packages /tmp/fai_smart.patch</pre>
  
=== install FAI ConfigFiles for SLES9 ===
+
== Install FAI ConfigFiles for SLES9 ==
 
# get config
 
# get config
 
#:<pre>wget http://altf4.org/fai/faiconfig_with_SLES9_basefile.tgz -O /tmp/faiconfig_with_SLES9_basefile.tgz</pre>
 
#:<pre>wget http://altf4.org/fai/faiconfig_with_SLES9_basefile.tgz -O /tmp/faiconfig_with_SLES9_basefile.tgz</pre>
Line 24: Line 29:
 
#:<pre>cd /srv/fai/config && tar xvfz /tmp/faiconfig_with_SLES9_basefile.tgz</pre>
 
#:<pre>cd /srv/fai/config && tar xvfz /tmp/faiconfig_with_SLES9_basefile.tgz</pre>
  
=== configure FAI for SLES9 ===
+
== Configure FAI for SLES9 ==
 
# edit '''/srv/fai/config/class/50-host-classes''' and add the classes "SUSE" and "SLES932BIT" to the SLES9-Client.
 
# edit '''/srv/fai/config/class/50-host-classes''' and add the classes "SUSE" and "SLES932BIT" to the SLES9-Client.
 
# edit '''/srv/fai/config/files/etc/smart/channels/sles932bit.channel/SLES932BIT''' and change the path to your Yast-Repository  
 
# edit '''/srv/fai/config/files/etc/smart/channels/sles932bit.channel/SLES932BIT''' and change the path to your Yast-Repository  
Line 46: Line 51:
 
fi
 
fi
 
</pre>
 
</pre>
 +
 +
 +
[[Category:Howto]]
 +
[[Category:SuSE]]

Latest revision as of 11:00, 4 October 2010

Introduction

It is possible to install Suse with FAI and we do this successfully. We do it with the speciality that we don't use yast for package management but smartpm, and documented this here.

For some generic information on using FAI with other distributions, you can look at the FAI multi-distribution page.

Create Yast Repository

  1. Copy all SLES9*.iso files to /var/www/SuSE/SLES9_repository
  2. get make_sles9_repository Script
    wget http://altf4.org/fai/SuSE/make_sles9_repository.sh && wget http://altf4.org/fai/SuSE/upgrade_sles9repository_withsp.sh
  3. make it executable
    chmod 755 make_sles9_repository.sh upgrade_sles9repository_withsp.sh
  4. make Repository
    ./make_sles9_repository.sh
  5. if you have SP* iso files, to do
    ./upgrade_sles9repository_withsp.sh [SP]

Patch FAI install_packages for Smart

  1. get patch
    wget http://altf4.org/fai/SuSE/fai_smart.patch -O /tmp/fai_smart.patch
  2. patch /srv/fai/nfsroot/usr/sbin/install_packages
    patch /srv/fai/nfsroot/usr/sbin/install_packages /tmp/fai_smart.patch

Install FAI ConfigFiles for SLES9

  1. get config
    wget http://altf4.org/fai/faiconfig_with_SLES9_basefile.tgz -O /tmp/faiconfig_with_SLES9_basefile.tgz
  2. without basefiles faiconfig_without_SLES9_basefile.tgz
    wget http://altf4.org/fai/faiconfig_without_SLES9_basefile.tgz -O /tmp/faiconfig_without_SLES9_basefile.tgz
  3. install ConfigFiles
    cd /srv/fai/config && tar xvfz /tmp/faiconfig_with_SLES9_basefile.tgz

Configure FAI for SLES9

  1. edit /srv/fai/config/class/50-host-classes and add the classes "SUSE" and "SLES932BIT" to the SLES9-Client.
  2. edit /srv/fai/config/files/etc/smart/channels/sles932bit.channel/SLES932BIT and change the path to your Yast-Repository
  3. edit /srv/fai/config/scripts/LAST/50-misc and change the codeblock:
# Make sure everything is configured properly
echo "Running \"apt-get -f install\" for the last time."
$ROOTCMD apt-get -f install

# copy sources.list
fcopy -i /etc/apt/sources.list

to

if ifclass ! SUSE; then
        # Make sure everything is configured properly
        echo "Running \"apt-get -f install\" for the last time."
        $ROOTCMD apt-get -f install

        # copy sources.list
        fcopy -i /etc/apt/sources.list
fi